How To Fix mhotspot has Stopped Working Error Windows 7

I was trying to get my pc internet shared to my xperia android device, the two options i shortlisted was mHotspot and connectify, as connectify being limited and requires a purchase, i thought to give a try of mHotspot which seems to be free.

The installation of mHotspot was successful but i couldn't launch the application, it immediately crashed upon opening stating that "mHotspot had stopped working and needs to close.

I followed the instructions posted on mHostspot knowledgebase to enable Microsoft .net framework 3.5, but still the crash continued,

Here is how i got mHotspot working without crashing on windows 7 PC

I saw that my windows firewall service is under disabled mode.This is the main reason for the mHotspot to crash, i went ahead and enabled the windows firewall through services.msc and started the firewall service and and launched mHotspot

mhotspot launched successfully on windows 7 without crashing.

This is my analysis about the crash.

When windows firewall service is under disabled mode, the Internet connection sharing is not possible, if you got to a lan adapter properties and try to enable the ICS, it would throw the following error, as mHotspot is based out of ICS, its causing the application to crash.

cannot enable shared access Error:0x80004005: unspecified error


enable the firewall and start the windows firewall service through run--Services.msc and Windows Firewall.

Discuss more about the fix using the below comments section from hp answers.

HP Answers


  1. Hello,
    I tried to launch mHotspot app from my PC running Win7. Verified .Net 3.5 and also Windows Firewall are fine.
    Even tough I am not able to launch the application, the same error.
    I tried uninstalling the app and again installed from Administrator account and found the same error while launching from Administrator account.

    Any idea...

  2. Hi Raghu, are you connected to any VPN?

  3. I have the same problem as Raghu. I am not connected to a VPN but I am connected to my work's network. Any suggestions?

  4. same error as reported by Raghu and Matty... can anyone help to fix this matter.. tried installing multiple times and various versions but still... same error..